Hub Planner is supported by the latest versions of Google Chrome, Mozilla Firefox, Apple Safari and Microsoft Internet Explorer. In order to experience Hub Planner website fully, please upgrade to the latest version of one of the following browsers:

  • Google Chrome
  • Mozilla Firefox
  • Apple Safari
  • Microsoft Internet Explorer (version 7 and above)

Hub Planner is fully compatible with Mac OSX and Windows Operating Systems.

Hub Planner has support for Tablet devices such as the iPad and mobile devices such as the iPhone.

this text.